Close

User Tag List

Results 1 to 8 of 8
  1. #1
    Junior Member wea8675309's Avatar
    Join Date
    Oct 2013
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Can't disable menu and back buttons

    I'm trying to disable the menu and back buttons. I've referred to several tutorials, but the one specific to the Note 2 came from this forum (found here: [HOW TO] Add Soft Keys to Screen).

    According to the tutorial, to do this I have to comment out the following lines in /system/usr/keylayout/generic.kl :

    Code:
    key 139 MENU          WAKE_DROPPED 
    key 159 BACK          WAKE_DROPPED
    so that they look like

    Code:
    # key 139 MENU          WAKE_DROPPED 
    # key 159 BACK          WAKE_DROPPED
    I successfully did this using ES File Explorer. I then rebooted my phone, only to find that the buttons still work. I tried deleting those lines completely (after making a backup of the file). This did not work either.

    I have enabled the navigation bar through Paranoid Android's custom settings menu. I have also disabled the backlight for both buttons through the settings menu as well. This is the only part of the tutorial I am using. I just want these buttons effectively disabled. Alternate methods, such as simply unmapping their functions, would suffice (or is that what I'm trying to do?)

    Regardless, I'm confused as to why this method isn't working. No one else seems to have had trouble with it.

    Additional info:
    Running Android 4.3 via the Paranoid 3.99 ROM (could this have anything to do with it?)
    Using the Verizon model of the Note 2 (SCH-I605)

  2. #2
    Administrator Bkdodger's Avatar
    Join Date
    Oct 2012
    Location
    Brooklyn, N.Y.
    Posts
    15,852
    Mentioned
    98 Post(s)
    Tagged
    1 Thread(s)
    Welcome to the forum. ..I've not tried the mod but I'm sure someone will be here with advice. ..
    "Nothing great was ever achieved without enthusiasm"

    FOLLOW FORUM RULES HERE!!


  3. #3
    Junior Member wea8675309's Avatar
    Join Date
    Oct 2013
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Bkdodger View Post
    Welcome to the forum. ..I've not tried the mod but I'm sure someone will be here with advice. ..
    Thank you!

  4. #4
    Senior Member Miller6386's Avatar
    Join Date
    Jun 2013
    Posts
    943
    Mentioned
    62 Post(s)
    Tagged
    0 Thread(s)
    Doesn't PA offer an option to reassign those buttons and then just set them to blank.... if not I'm pretty sure I saw a killer for those buttons somewhere that was flash able. I think it was in the INT version thread at xda under themes and apps....

  5. #5
    Junior Member wea8675309's Avatar
    Join Date
    Oct 2013
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Miller6386 View Post
    Doesn't PA offer an option to reassign those buttons and then just set them to blank.... if not I'm pretty sure I saw a killer for those buttons somewhere that was flash able. I think it was in the INT version thread at xda under themes and apps....
    Unfortunately the version I'm using only allows me to map/unmap long presses. I just installed Carbon v1.8 with Android 4.2.2 and it allows me to do this. I would prefer to use 4.3, but this should do for now.

    It still begs the question as to why the above method wouldn't work. That seemed like a pretty straightforward mod. I checked the rest of the .kl files in the keyboardlayout folder and none of them assign any values to keys 139 and 158. Not to mention no one else on the internet seems to be having this problem.

  6. #6
    Senior Member Miller6386's Avatar
    Join Date
    Jun 2013
    Posts
    943
    Mentioned
    62 Post(s)
    Tagged
    0 Thread(s)
    In your post up above you show # key it should be #key when commenting out lines. Also that write up is for an older version of Android. They could of changed something in the newer builds. I doubt that but it's possible.....

  7. #7
    Senior Member Miller6386's Avatar
    Join Date
    Jun 2013
    Posts
    943
    Mentioned
    62 Post(s)
    Tagged
    0 Thread(s)
    Also I don't think it should be the wake locked values that get commented out...... it's been a while since I've played in there but that seems wrong....

  8. #8
    Junior Member wea8675309's Avatar
    Join Date
    Oct 2013
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Miller6386 View Post
    In your post up above you show # key it should be #key when commenting out lines. Also that write up is for an older version of Android. They could of changed something in the newer builds. I doubt that but it's possible.....
    Tried it. Also tried deleting the lines completely.

    Quote Originally Posted by Miller6386 View Post
    Also I don't think it should be the wake locked values that get commented out...... it's been a while since I've played in there but that seems wrong....
    This sounds right. I was following the tutorial to the letter, since so many people seemed to have success with it. But now that you mention it, it doesn't make much sense.

    Regardless, I've been able to achieve what I wanted through the latest iteration of the Carbon ROM. Pretty sure you nailed it, though.

Remove Ads

Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Search tags for this page

carbon rom backlite softkey
,
disable back ans menu botton on note 3
,
disable back button and menu on galaxy note 3
,

disable back button android

,
disable butoons galaxy note 2
,

disable menu and back button android

,
galaxy note 8 disable back button
,
how to disable the back and menu buttons in the galaxy tab 3
,
how to unable the back button in note 2
,
samsung galaxy tab 3 disable back button
Click on a term to search for related topics.